XOOPSインストールする以前にHTTP500エラーが出る-後日談

ちょっと今回はさすがに頭に来た。
数年前から、アイルのサポートには、いろいろと思うところがあったけど、それでもとんちんかんコピペ回答から答えを導き出せていたから、まぁいいかと思ってました。
しかし、もちろんお客様にはサーバーを勧めなくなりました。一回サーバーの仕様変更があって、IDやパスワードやFTP情報がごそっと変わったときがあったのですが、そのとき配布されたマニュアルの一番肝心なところが記述ミスで、半日ぐらいそれにかかりっきりだったことがあります。しかも解決したのは、「まーさーかーねー」と思いながら試してみた方法がどんぴしゃだったから。アイルのサポート、まったく電話つながらないし。

そのときから、「アイルはもうやめような?」って言ってたんですけど、今回はお客様の関係でアイルに頼みました。

しかし、今回もやってくれた。アイルのサポート。

3日ぐらいの間に5回ほどメールをやりとりしたんですけど(だって電話つながらないし)、一番最初に「wwwrootだとだめなんですかね?」と私が聞いて、アイルが「動きますよ」といったのにも関わらず、なんとかプログラムをインストールして、全部設定して、コンテンツも全部何もかも完成させたあとに「wwwr/wwwroot 直下にCGIやPHPなどのファイルを設置すると
正しく動作出来ないケースがあることが確認できました」という返答。

なめてるのかと。
最初に聞いたじゃないかと。
自社製品の仕様もよくわかっていない人が、サポート(しかも「技術」の)してるのってどうなのだと。
おかげで余計な時間をかけて、再度設定しなおしかと。
階層変えて、設定ファイルの記述かえるだけかもしれないけど、念のため、今問題なく動いているファイルを全部ダウンロードして使うのにどれぐらい時間がかかると思ってるんだ! 今現在で2時間だぞ! すぐに何か切れるし!!

で、メールのやりとりも残しておきます。


○○○様の代理で質問させていただきます。
御社のInfinito(PLUSではない)を契約させていただいています。
XOOPSを入れようと、御社で用意していただいているマニュアルを元に、インストールをしようとしているのですが、index.phpに接続するとHTTP500内部サーバーエラーが出ます。

installフォルダをたたくと、インストールが始まり、インストール完了するのですが、index.phpがHTTP500内部サーバーエラーで反応しません。

kyoto-tanbapark.or.jpのドメインのホスティングのウェブスペース設定をwwwrootに設定し、XOOPSのファイルもwwwroot直下に入れているのが悪いのでしょうか?

前に、
example.comのドメインのホスティングを、wwwroot/example.comというフォルダにして、そこへxoopsのファイルを入れたときは、うまく起動したように思います。

wwwrootを直接、ウェブスペース設定するのはよくないでしょうか?

よろしくお願いします。

——————————————————————————-
アイル
お問い合わせの件についてご案内いたします。

インストールをする場所はどこでも問題はございません。

データベースの設定に問題がある可能性がございますので
インストール時の入力項目について再度ご確認をお願いできますでしょうか。
また、フォルダへのアクセス権で、書き込み権限が付与されているかも
合わせてCONTROL PANLEのファイルマネージャーにてご確認をお願いいたします。

何かご不明な点がございましたら、お気軽にお問い合わせください。

——————————————————————————-

********で質問にお答えいただきました。ありがとうございます。

「データベースの設定に問題がある可能性がございます」というお答えいただいておりますが、それ以前の問題だと思います。ファイルの権限も直しています。mainfile.phpなどのファイルやフォルダの権限は直しました。
その中にindex.phpの権限の変更はマニュアルになかったように思います。

wwwrootに、御社の提供しているXOOPSのファイルを展開(html以下のみアップロード)。
http://example.com/をたたくと、HTTP500内部エラー。
http://example.com/index.phpでも同様です。
普通は、installフォルダに自動的に飛ぶのに、飛びません。
データベースの設定は、installが展開してから打ち込んでいくので、データベースの設定は関係ないはずです。
この時点で、index.phpがHTTP500内部エラーを出す理由ってわかりますでしょうか?

あと、気になっているのは、ドメイン移行前なので、
http://(デフォルトドメイン)/index.php
というアドレスで見ているということです。これも関係しますでしょうか?

あと、エラーログの見方がわからないので、どこでエラーログを確認できるか教えてください。コントロールパネルなどのマニュアルを読んでもわかりませんでした。
——————————————————————————-
アイル

お問い合わせの件についてご案内いたします。

DNSの切り替え前との事でございますが、仰るとおり
http://www.デフォルトドメイン/ のURLでは
プログラムの動作の確認を頂くことが出来ません。
初回の問い合わせの際に、DNSの状態が確認できておらず
誠に申し訳ございませんでした。

DNS切り替え前にプログラムの動作をご確認される場合は、
hostsファイルの設定が必要となります。
下記のURLをご確認頂き設定をお試しいただけますでしょうか。

■DNSの切替え前にプログラムの動作確認をしたい
http://winfaq.isle.jp/FaqItem?i_faqId=241&i_categoryId=532

お手数をおかけいたしますが、よろしくお願いいたします。
ご不明な点がございましたら、お気軽にお問い合わせください。

——————————————————————————-
私(1通目)
1通目は記録にのこってないです。

■DNSの切替え前にプログラムの動作確認をしたい に載っているhostsの設定でも動かなかったというような意見だったかと思います。

また、hostsの設定で動かなかった場合は、デフォルトドメインでということが、教えていただいたURLには載っています。

——————————————————————————
私(2通目)
2*******と2*******で返答いただき、先ほど再度メールいたしました。

XOOPSのインストールですが、
index.phpを変更したら、うまくいきました。

require_once ‘./mainfile.php’;

require_once ‘mainfile.php’;
に変更で、

2*******の回答では、
http://デフォルトドメイン/index.php
では、プログラムの動作の確認を頂くことが出来ません。
とおっしゃられたのですが、
http://デフォルトドメイン/index.php
でちゃんと動きました。

たまに、「./」を禁止しているサーバーがあると聞きますが、御社のサーバーがそうなのではないでしょうか?
wwwroot/example/では動いて、
wwwroot/では動かなかった理由が、それでなんとなくわかる気がしますが。
なんか、ちゃんと読んで対応していただけているのか、不安ですが。
一応、質問させていただいてましたので、報告させていただきます。

エラーログの見方、教えてください。

——————————————————————————-
アイル
エラーログに関しまして、ご案内が行なえておらず誠に申し訳ございません。
改めでご案内をいたします。

誠に恐れ入りますが、ご利用いただいておりますサーバーは共用サーバーとなり、
Webサーバーのログの提供を行っていないため、お客様にてエラーのログを
ご参照いただくことが出来ません。
ご要望にお応えできず誠にもうしわけございませんが、
何卒ご了承いただきますようお願いいたします。

また、「./」の表記に関しましては、ドメインにて弊社サーバーに
接続いただくケースでは問題なくご利用いただくことが可能となっております。

「./」をはずしていただいたことにより動作が出来るようになったとのことで
ございますが、症状について現在確認いたしておりますので、
今しばらくお待ちいただけますでしょうか。

ドメイン名にて接続が出来る状態である場合はxoopsのデフォルトのファイルの状態にて
接続が可能であることを確認いたしておりますので、hostsファイルの設定を
今一度お試頂くことをおすすめいたします。

尚、hostsファイルの設定は弊社独自の設定方法ではなく、PC内でのホスト名の
名前解決を予め設定できる方法として一般的にご利用いただける方法となります。
hostsファイル設定後も旧サーバーのページが表示されてしまう場合は、
正しくhostsファイルが設置いただけていない状況となります。

お調べいたしましたところ、お客様のご利用サーバーのIPアドレスは、
***.***.***.** の形のものとなっておりました。

***.***.***.** www.example.com
***.***.***.** example.com

上記2行のような形にて弊社環境にてhostsファイルに追記を行い、
pingにてホスト名の接続先の確認を行なったところ、
新サーバーへつながる状態を確認いたしております。
お手数ではございますが再度お試しいただけますようお願いいたします。

※新サーバーのIPアドレスはご契約情報となりますため、
 ご契約メールアドレス以外にお伝えすることが出来ません。
 FAQに記載されております方法にてIPアドレスをご確認の上、
 ご設定をお願いいたします。

お手数をおかけいたしますが、よろしくお願いいたします。
ご不明な点がございましたら、お気軽にお問い合わせください。

—————————————————————–
私(残っていませんが)
hostsの設定がうまくいかなかったのは、弊社のネット環境のせい(プロキシ経由)でした。
すみませんでした。
ネット環境をかえたところ、hostの設定は通りましたが、
やはり、index.phpを「./」付にするとエラーがでて動きません。

「./」付でなければ動きますし、時間もさしせまっておりますので、
それで進めたいと思います。

—————————————————————–
アイル
回答にお時間を賜りましてありがとうございました。
お問い合わせの件についてご案内いたします。

弊社環境にて検証を行ないましたところ、Infinito サーバーでは
/wwwroot 直下にCGIやPHPなどのファイルを設置すると
正しく動作出来ないケースがあることが確認できました。

これは、「wwwroot」ディレクトリ自体を改変することができないよう
セキュリティ対策を講じているためになります。

恐れ入りますが、「wwwroot」ディレクトリ直下にファイルを設置せず、
「wwwroot」ディレクトリに新たにディレクトリを作成し、そのディレクトリを
ドメインのウェブホスティングの「場所」に設定をお願いいたします。

お手数をおかけいたしますが、よろしくお願いいたします。

—————————————————————–

—————————————————————–

まぁ、よく読むと、「wwwroot」でもOKの範囲の読み違いが問題かなと。
「wwwroot」でプログラムが動かないケースがあるということを、最初から把握できてればよかったのかなーなんて思いますけど。


コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です