ToolbarComponent.php on line 174

cakePHP使ったアプリケーションで

Parse error: syntax error, unexpected T_FUNCTION in Plugin\DebugKit\Controller\Component\ToolbarComponent.php on line 174

のエラーが出た場合は、PHPのバージョンを確かめること。5.3以下だと使えない。

けど、こちらの記事

PHP5.3以上のときだけDebugKitを読み込む

で、PHP5.3以下でも動くようになるようです。

まえにも似たようなことをして、解決したのに、また忘れそうなのでメモメモ!!